PHPのバージョンはいくつですか?

猫を洗った後、乾かすのが大変なYu-ichiですneko.gif

先日の地震の時もそうでしたが、うちの猫が荒ぶって家中を走り回ると大きめの地震が起こります。何か感じてるんですかね。cat_6.gif

さて、PHPのバージョンはいくつを使っていますか?
5.6以前を使っている方・・・
セキュリティの為にバージョンを上げておきましょう!

5.6を使っている方・・・
たぶん一番多いんじゃないでしょうか。

7を使っている方・・・
進んでますね!

PHP7は2015年に出ていますが、使っている方はあまり多くないようです。
さて、ここで疑問に思うことは無いでしょうか?
そうです、PHP5.6→7となっており、PHP6がありません。

何故PHP6は無いの??

実は、PHP5.6の後継として開発は行われていました。cat_5.gif
PHP6の大きな方針として、「内部の文字列をUTF-16で実装する」ことになっていたようですが、労力に見合うだけのメリットがほとんど無くお蔵入りしたそうです。naku02.gif
その代わりに、新たなプロジェクトとしてPHP7の開発が進められたそうです。
(かれこれ6年くらい前のお話ですが・・・。)

そして新に登場したPHP7ですが、5.6と比べると飛躍的に改善されています。emoji206.gif
特に2倍以上の性能向上メモリ使用量の低減など、
PCだけでなくスマホなどのモバイル端末にとっては大きな改善ではないでしょうか。w01.gif

PHP5.6を使い続ける理由が無いのであれば、すぐにでも7へ移行するべきだと思います。neko.gif

この記事が投稿される時間に、私は毎年恒例の鐘突に行っているでしょうw
今年も混んでるだろうなぁ・・・。

それでは、また来年もよろしくお願いします。

No related posts.

トラックバックURL